Hola buen día hermanos vamos a realizar una configuración básica de MikroTik con vlans, les dejo el Script en la parte de abajo esta configuración tendrá lo siguiente en resumidas cuentas.

El equipo al cual se le realizará la configuración es un MikroTik modelosoftware id = X385-A5MH model = RB941-2nD
La configuración final qué obtendrás será está

Los puertos ether1,ether2,ether3,wlan1 los dejamos de gestion con PVID 1
El puerto 4 en el vlan21 PVID 21
En wlan2 en vlan22 PVID 22

Conectamos el MikroTik a la luz, de nuestro router de internet sacamos un cable rj45 y la conectamos en el primer puerto del MikroTik

Nos conectamos por medio de wi-fi o cable al router de internet y por medio de winbox entramos al MikroTik, en este caso los reseteare completamente para que sea una configuración limpia .

Al resetearlo te pedirá la contraseña le colocas una y te vuelves a conectar.

Redes wifi wlan1 con ssid Privado y wlan2 virtual con ssid Invitados

Crearemos dos redes wifi con wlan1 y wlan2 ,y con perfil de seguridad:
Para los perfiles de seguridad ir a wireless> security-profiles

Hacerlo manualname=pass
mode=dynamic-keys
authentication-types=wpa-psk,wpa2-psk
wpa-pre-shared-key=123456789
wpa2-pre-shared-key=123456789
management-protection=disabled
En la terminal/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" mode=dynamic-keys name=pass supplicant-identity="" wpa-pre-shared-key=123456789 wpa2-pre-shared-key=123456789
Redes wifi wlan1 con ssid Privado y wlan2 virtual con ssid Invitados

Y las interfaces wifi en wireless

Forma manualdefault-name=wlan1
mode=ap-bridge band=2ghz-g/n
ssid=Privado security-profile=pass
wps-mode=disabled
Terminal/interface wireless
set [ find default-name=wlan1 ] band=2ghz-g/n mode=ap-bridge \security-profile=pass ssid=Privado wireless-protocol=802.11 wps-mode=\disabled

Y el wlan2 virtual en + virtual

Manualmaster-interface=wlan1
name=wlan2
security-profile=pass
ssid=Invitados
wps-mode=disabled
Terminal/interface wireless
add keepalive-frames=disabled mac-address=66:D1:54:14:61:18 master-interface=\wlan1 multicast-buffering=disabled name=wlan2 security-profile=pass ssid=\Invitados wds-cost-range=0 wds-default-cost=0 wps-mode=disabled

BridgeWAN y BridgeLAN y Vlans en mikrotik

ManualCreamos los bridges bridgeWAN y bridgeLAN en Bridge>bridge
y en brigdeLAN Activar VLAN Filtering en la pestaña VLAN
Consola/interface bridge
add name="bridgeLAN " vlan-filtering=yes
add name=bridgeWAN

Creando las Vlan21 , Vlan22 y colocando puertos

ManualNos vamos a interfaces>VLAN y creamos los vlans ,
vlan21 con ID 21 dentro de bridgeLAN
vlan22 con ID 22 dentro de bridgeLAN


Se ponen los puertos, en Bridge>ports
En bridgeWAN metemos el ether 1 y se reiniciara…
En el bridgeLAN metemos el: ether 2,ether 3,ether 4, wlan1,wlan2
Terminal/interface vlan
add interface=bridgeLAN name=vlan21 vlan-id=21
add interface=bridgeLAN name=vlan22 vlan-id=22


/interface bridge port
add bridge="bridgeLAN " interface=ether2
add bridge="bridgeLAN " interface=ether3
add bridge="bridgeLAN " interface=ether4 pvid=21
add bridge="bridgeLAN " interface=wlan1
add bridge="bridgeLAN " interface=wlan2 pvid=22
add bridge=bridgeWAN interface=ether1

Listado de interfaces y acomodo de bridges

ManualCreamos una lista de interfaces en interfaces>Interfaces list>list +
WANs ,LANs y VLANs
Después metemos los Bridge a la lista de interfaces en interfaces>Interfaces list +
En la WANs metemos bridgeWAN , en LANs metemos bridgeLAN
y en las VLANs metemos las vlan21 y vlan22
Terminal
/interface list
add name="WANs "
add name="LANs "
add name=VLANs
/interface list member
add interface=bridgeWAN list="WANs "
add interface=vlan21 list=VLANs
add interface=vlan22 list=VLANs
add interface="bridgeLAN " list="LANs "

Dhcp cliente , direcciones ip,dhcp servers y nateo

Creamos el dhcp cliente en ip>dhcp-client +
En el bridgeWAN

/ip dhcp-client
add disabled=no interface=bridgeWAN 

Ahora creamos las direcciones que por default aparece la que creamos en el paso anterior en dhcp cliente en IP>address + y colocamos la siguiente configuracion

/ip address
add address=10.0.0.1/24 interface="bridgeLAN " network=10.0.0.0
add address=172.21.1.1/24 interface=vlan21 network=172.21.1.0
add address=172.22.1.1/24 interface=vlan22 network=172.22.1.0

Ahora creamos los dhcp server en IP>Dhcp-server y utiliza el wizard que lo hace en automatico, para bridgeLAN , Vlan21 y vlan22

/ip dhcp-server network
add address=10.0.0.0/24 gateway=10.0.0.1
add address=172.21.1.0/24 gateway=172.21.1.1
add address=172.22.1.0/24 gateway=172.22.1.1
/ip pool
add name=dhcp_pool0 ranges=10.0.0.2-10.0.0.254
add name=dhcp_pool1 ranges=172.21.1.2-172.21.1.254
add name=dhcp_pool2 ranges=172.22.1.2-172.22.1.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface="bridgeLAN " name=dhcp1
add address-pool=dhcp_pool1 disabled=no interface=vlan21 name=dhcp2
add address-pool=dhcp_pool2 disabled=no interface=vlan22 name=dhcp3

Ahora realizamos el Nateo para poder darle salida a internet en ip>firewall>nat + en la pestaña General
Out interface list ponemos WANs y en la pestaña Action poner masquerade

/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\"place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat out-interface-list="WANs "

Y para la gestion de vlans agregamos una serie de reglas en el firewall

  • Se crea la regla universal aceptar lo establecido y relacionado de la ocupacion del router
  • Todo lo que venga de la WLANs a las VLANs se acepta
  • todo lo que salga de las VLANs hacia la WANs se acepta
  • Todo lo que vaya de las VLANs a cualquiera se denega
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment=\"place hotspot rules here" disabled=yes
add action=passthrough chain=unused-hs-chain comment=\"place hotspot rules here" disabled=yes
add action=accept chain=forward connection-state=established,related
add action=accept chain=forward in-interface-list=WANs out-interface-list=\VLANs
add action=accept chain=forward in-interface-list=VLANs out-interface-list=\WANs
add action=drop chain=forward in-interface-list=VLANs
add action=drop chain=input in-interface-list=VLANs

Acomodo de puertos en PVIDs y taggeo

Acomodo los puertos en Bridge>ports
Activar PVID en Bridge port, para ver la pestaña extra PVID
Los puertos ether1,ether2,ether3,wlan1 los dejamos de gestion con PVID 1
el puerto ether4 en el vlan21 PVID 21
En wlan2 PVID 22

EN BRidge>VLANs Realizar el taggeo

ManualBridge= bridgeLAN
VLAN IDs = 1
Untagged= wlan1,ether1,ether2,ether3,bridgeLAN

Bridge= bridgeLAN
VLAN IDs = 21
Untagged= ether4
Tagged= wlan1,ether1,ether2,ether3,bridgeLAN

Bridge= bridgeLAN
VLAN IDs = 22
Untagged= wlan2
Tagged= wlan1,ether1,ether2,ether3,ether4,bridgeLAN
Terminal
/interface bridge vlan
add bridge="bridgeLAN " untagged="wlan1,ether1,ether2,ether3,bridgeLAN " \vlan-ids=1
add bridge="bridgeLAN " tagged="wlan1,ether1,ether2,ether3,bridgeLAN " \untagged=ether4 vlan-ids=21
add bridge="bridgeLAN " tagged="wlan1,ether1,ether2,ether3,ether4,bridgeLAN " \untagged=wlan2 vlan-ids=22

Configuracion del hostpot en el ether2 , portal,usuario y perfil de usuario

  • Perfil de Velocidades para clientes
/ip hotspot user profile
set [ find default=yes ] name=ilimitada
add !keepalive-timeout name=2mb rate-limit=1M/2M
add !keepalive-timeout name=3mb rate-limit=2M/3M
add !keepalive-timeout name=5mb rate-limit=2M/5M
  • Perfil del hotspot, estara en brigdeLAN por lo que el gateway sera 10.0.0.1
/ip hotspot profile
add dns-name=wifirivera.com hotspot-address=10.0.0.1 login-by=\cookie,http-chap,trial,mac-cookie name=hsprof1 trial-uptime-limit=1d \trial-uptime-reset=5d trial-user-profile=3mb
  • Hotspot en brigdeLAN
/ip hotspot
add address-pool=dhcp_pool0 disabled=no interface=bridgeLAN name=hotspot1 \profile=hsprof1

-Creando usuarios de prueba

/ip hotspot user
add name=abdias password=abdias
add comment=vc-756-11.26.21-Voucher1h limit-uptime=1h name=1H2FVSD password=\1H2FVSD profile=2mb server=hotspot1
  • Adicional cambiar reloj y nombre del router mikrotik
/system clock
set time-zone-name=America/Mexico_City
/system identity
set name="MKT Router"

Para cambiar el tema ,borras todo lo que haya en Files y colocas este tema mikrotik premium
Y el script de configuracion vlans milkrotik para descargar

5/5 - (1 voto)